Requirements

The following matrix shows which minimum version of Java is necessary to run a specific Weka version. The latest official releases of Weka require Java 8 or later.

  Java
1.4 1.5 1.6 1.7 1.8
WEKA <3.4.0 X X X X X
3.4.x X X X X X
3.5.x 3.5.0-3.5.2 >3.5.2
X X X
3.6.x   X X X X
3.7.x   3.7.0 >3.7.0
>3.7.13 X
3.8.x   3.8.0-3.8.1 >3.8.1
3.9.x    
3.9.0-3.9.1 >3.9.1